1. كل المواضيع تعبّر عن رأي صاحبها فقط و ادارة المنتدى غير مسؤولة عن محتوياتها
    إستبعاد الملاحظة

code prét mais il a besoin d'un peu de ...

الموضوع في 'English & French Archive' بواسطة asfm12, بتاريخ ‏25 أكتوبر 2007.

حالة الموضوع:
مغلق
  1. asfm12

    asfm12 عضو نشيط

    إنضم إلينا في:
    ‏20 جويلية 2007
    المشاركات:
    194
    الإعجابات المتلقاة:
    9
      25-10-2007 11:50
    ok salut tout le monde cé t'un code qui permet de récuperer un ficjier excel dans un tableau en windev (tableau dynamique la probléme cé ue le tableau naffiche pas correctemment tout il affiche en meme colonne

    AfficherFichierTexte est une chaîne
    sCheminFichier est une chaîne = ""
    sFiltre est une chaîne = "Fichier excel (*.xls)" + TAB + "*.xls" + RC + "Tous (*.*)" + TAB + "*.*"
    gsSélectionnerFichier est une chaîne
    idfichier est un entier
    i est un entier=1
    num_col est un entier
    num_lig est un entier
    Col est un entier
    Lig est un entier
    resDonnée est un entier


    // Sélectionner un fichier
    // Appel du composant
    sCheminFichier = fSélecteur("", "", "Sélectionner un fichier excel...", sFiltre, ".xls", fselOuvre + fselExiste)
    idfichier = xlsOuvre(sCheminFichier)
    num_col=xlsNbColonne(idfichier,Vrai)
    num_lig=xlsNbLigne(idfichier,Vrai)

    //Code de Récupération de données

    SI idfichier<>-1 ALORS
    POUR Col=1 A num_col
    POUR Lig=2 A num_lig
    resDonnée=xlsDonnée(idfichier,Lig,Col,Vrai)
    TableAjoute(t1,resDonnée)
    FIN
    FIN
    FIN
     
  2. asfm12

    asfm12 عضو نشيط

    إنضم إلينا في:
    ‏20 جويلية 2007
    المشاركات:
    194
    الإعجابات المتلقاة:
    9
      07-11-2007 16:44
    et bain les amis chui arrivé au solutions
    il ya un manque de deux lignes de programmations:dance:
     
حالة الموضوع:
مغلق

مشاركة هذه الصفحة

جاري تحميل الصفحة...