tri d'une matrice

الموضوع في 'أرشيف المنتدى التعليمي' بواسطة barhoum007, بتاريخ ‏1 مارس 2008.

  1. barhoum007

    barhoum007 عضو جديد

    إنضم إلينا في:
    ‏28 ديسمبر 2007
    المشاركات:
    26
    الإعجابات المتلقاة:
    4
      01-03-2008 12:46
    salut les amis
    je veux un algorithme qui trie une matrice et merci
     
  2. waliminem

    waliminem كبار الشخصيات

    إنضم إلينا في:
    ‏10 فيفري 2008
    المشاركات:
    2.208
    الإعجابات المتلقاة:
    10.086
      01-03-2008 16:31
    tu dois trier chaque ligne de la matrice avec n'importe quelle methode de tri que tu connait et c'est pas la peine que quelqu'un d'autre fait la solution
     
    • 01-03-2008 21:02
    بالطبيعة انت يلزمك تحاول الاول بعد تفركس عالحل

    هاو باش نعكيط رؤوس الاقلام:

    - fait un parcour de matrice

    exemple

    pour i de 1 a n faire
    pour j de 1 à n faire
    algorithme de tri

    tu a tri par insertion ou tri par selection ou tri à bulle

    et pour moi je préfére le tri à bulle c'est le plus simple


    merci
     
    1 person likes this.
  3. scoubydoo

    scoubydoo عضو نشيط

    إنضم إلينا في:
    ‏25 جانفي 2007
    المشاركات:
    134
    الإعجابات المتلقاة:
    21
      02-03-2008 14:58
    salam ,lazem ta3am parcours a chaque fois pour la matrice en cherchant le plus petit element et apres tu le met a ca place finaleen le permutant avec celui ki ce trouve a ca place
    si tu ve la nuit je te donne la solution final comme tu ve en c ou en pascal
     
  4. houssemaster

    houssemaster عضو جديد

    إنضم إلينا في:
    ‏19 فيفري 2008
    المشاركات:
    43
    الإعجابات المتلقاة:
    35
      02-03-2008 17:44
    tu peut mettre tout les éléments du matrice dans un tableau 1demension puis tu trie ce dernier et finalement tu les retourne dans la matrice

    mais la taille du tableau il faut qu'il égale a nb de lignes *nb de colonnes.
    bon chance.
     
  5. barhoum007

    barhoum007 عضو جديد

    إنضم إلينا في:
    ‏28 ديسمبر 2007
    المشاركات:
    26
    الإعجابات المتلقاة:
    4
      02-03-2008 21:21
    je veux une solution et pas du bla bla bla
     
  6. barhoum007

    barhoum007 عضو جديد

    إنضم إلينا في:
    ‏28 ديسمبر 2007
    المشاركات:
    26
    الإعجابات المتلقاة:
    4
      02-03-2008 21:49
    donne la solution en pascal et merci
     
  7. minokado

    minokado عضو مميز

    إنضم إلينا في:
    ‏8 نوفمبر 2006
    المشاركات:
    1.007
    الإعجابات المتلقاة:
    137
      05-03-2008 18:52
    tu peux proposer une solution et nous sommes là pour vous corriger les fautes
    mais la paresse el kedma 7adra n'est pas efficace cher frère
    et si tu n'y arrive pas je t'aiderai sans doute
    on vous attend
     
  8. ammar.mars

    ammar.mars عضو نشيط

    إنضم إلينا في:
    ‏6 جانفي 2008
    المشاركات:
    177
    الإعجابات المتلقاة:
    22
      09-03-2008 12:04
    il faut trier le matrice verticalement puis horizontalement avec n'importe quelle methode
     
  9. elwalid2

    elwalid2 عضو

    إنضم إلينا في:
    ‏17 أكتوبر 2007
    المشاركات:
    50
    الإعجابات المتلقاة:
    4
      09-03-2008 17:24
    algorithme _tri;
    var t : tableau(1..100) d'entier;
    i,j : entiers;
    debut
    repeter lire (n) jusqu' à (n>0) et (n<=100)
    pour i:=1 à n faire
    ecrire"entrez un nombre"
    lire (T);
    finpour
    pour i:=1 a n-1 faire
    pour j:=1 a n faire
    si T(j)<T(i) alors
    int:= T(i);
    T(j):=T(i);
    T(i):=int;
    fsi;
    finpour; finpour;
    ecrire('le tableau est trié');
    pour i:=1 a n faire
    ecrire(T(i))
    finpour;
    FIN.
     

مشاركة هذه الصفحة

جاري تحميل الصفحة...