la solution de cet exercice SVP

الموضوع في 'أرشيف المنتدى التعليمي' بواسطة Hassine Aymen, بتاريخ ‏18 جوان 2008.

  1. Hassine Aymen

    Hassine Aymen عضو فعال

    إنضم إلينا في:
    ‏18 ديسمبر 2007
    المشاركات:
    335
    الإعجابات المتلقاة:
    126
      18-06-2008 14:01
    Ecrire un algorithme qui permet de saisir un tableau de n entiers puis vérifié si un entier x saiair au clavier exister dans le tableau on non et dans le cas où x existe on affiche la position p de cet entier
     
  2. the_masque_001

    the_masque_001 عضو نشيط

    إنضم إلينا في:
    ‏11 فيفري 2008
    المشاركات:
    137
    الإعجابات المتلقاة:
    308
      18-06-2008 14:43
    voici ma propostion
    __________________________________________________________
    debut
    ecrire("donner la dimension du tableau")
    lire (n)
    tab= tableau[n]
    i=0
    tantque i<n
    faire
    ecrire ("donner un element ")
    lire tab
    fin tant que
    ecrire ("donner un elemnt ")
    lire (elem)
    i=0
    j=-1
    tantque i<n
    faire
    si tab=elem
    j=i
    fin tant que
    si j<0
    ecrire ("element introuveable")
    else
    ecrire("l'element saise à pour indice j")
    fin
     
  3. samm

    samm عضو مميز

    إنضم إلينا في:
    ‏11 جويلية 2006
    المشاركات:
    892
    الإعجابات المتلقاة:
    1.177
      18-06-2008 14:45
    fonction occ(x:entier;var t:tab;n:integer):entier
    var
    ok:entier


    i<--1
    tant que(t<>x)et (i<n) faire
    i<--i+1
    fin tan que
    si(t=x)alors
    ok<--i
    fin si
    occ<--ok
    fin fonction
     
  4. Kayser

    Kayser عضو

    إنضم إلينا في:
    ‏28 نوفمبر 2007
    المشاركات:
    80
    الإعجابات المتلقاة:
    52
      18-06-2008 15:21
    L'entier x peut se répéter plusieurs fois. Donc voici l'algo

    début recherche
    lire(n)
    pour i de 1 à n faire
    lire(t)
    finpour
    lire(x)

    trouve<-- faux
    i<--0
    répéter
    i<--i+1
    si t=x alors trouve<--vrai
    jusqu'à trouve=vrai ou i=n

    si trouve =faux alors ecrire(x," est introuvable")
    sinon
    début
    écrire(x,"se trouve dans t dans les positions:")
    pour j de i à n faire
    si t[j]=x alors écrire(j)
    Finsi

    fin recherche
     
  5. smartghost

    smartghost عضو

    إنضم إلينا في:
    ‏22 جوان 2007
    المشاركات:
    68
    الإعجابات المتلقاة:
    18
      18-06-2008 20:18
    pour la recherche de l'element X on peut aussi faire:
    i:=0
    repeter
    i:=i+1
    si t=X
    alors ecrire(i)
    jusqu'a i=n
     
  6. omar01

    omar01 عضو فعال

    إنضم إلينا في:
    ‏6 أفريل 2008
    المشاركات:
    533
    الإعجابات المتلقاة:
    155
      19-06-2008 17:41
    a3lech hata39id hetha kol mefih chay pg
     
  7. omar01

    omar01 عضو فعال

    إنضم إلينا في:
    ‏6 أفريل 2008
    المشاركات:
    533
    الإعجابات المتلقاة:
    155
      19-06-2008 18:13
    program appartien
    uses wincrt
    var
    ,x,i,n:integer
    t:array[1..100]of integer
    begin
    repeat
    writeln('donner le nombre de case')
    readln(n)
    until nin[5..20]
    for i :=1 to n do
    begin
    writeln('donner l'entier')
    readln(t)
    end;
    writeln('donner ton entier')
    readln(x)
    for i:=1 to n do
    begin
    if t=x then
    writeln('l'entier donneé appartient au tableau et sa position est',i)
    end;
    end.
    good luck
    by 0wAr!n0v!tCh
     

مشاركة هذه الصفحة

جاري تحميل الصفحة...