درس تعلم لغة - Windev - طريقة التصدير و الاستراد من اكسل الى ويندف والعكس

الموضوع في 'لغات البرمجة' بواسطة streamingall, بتاريخ ‏8 مارس 2016.

  1. Ahmed Jendoubi

    Ahmed Jendoubi Developpeur Windev طاقم الإدارة

    إنضم إلينا في:
    ‏17 جوان 2013
    المشاركات:
    3.074
    الإعجابات المتلقاة:
    5.128
      08-03-2016 17:45
    [​IMG]



    أهلا و سهلا بكافّة الإخوة الأعضاء والزوار في منتديات تونيزيا سات
    و مرحبا بكم في قسم التطوير و لغات البرمجة


    [​IMG]

    طريقة التصدير و الاستراد من اكسل الى ويندف والعكس

    [​IMG]





    كود Importer Fichier Xls

    كود (text):
    sFichier = fSélecteur("", "", "Sélectionnez un fichier...", "xls" + TAB + "*.xls", "*.xls")

    fich=xlsOuvre(sFichier,xlsEcriture)
    SI ErreurDétectée=Faux ALORS
        nBnrfeuil est un entier=xlsNbFeuille(fich)
        POUR i=1 A nBnrfeuil
            xlsFeuilleEnCours(fich,i)
            nBrcl est un entier=xlsNbColonne(fich,Faux)
            nBrli est un entier=xlsNbLigne(fich,Faux)
            TableAjouteLigne(Table1,i,nBrcl,nBrli)
        FIN
    FIN
    كود Lire Fichier Xls

    كود (text):
    xlsFeuilleEnCours(fich,Table1.Feuille)
    nBrli est un entier=xlsNbLigne(fich,Faux)
    TableSupprimeTout(Table2)
    Table2.Colonne1..Libellé=xlsDonnée(fich,1,1,Faux)
    Table2.Colonne2..Libellé=xlsDonnée(fich,1,2,Faux)
    Table2.Colonne3..Libellé=xlsDonnée(fich,1,3,Faux)
    POUR i=2 A nBrli
        TableAjouteLigne(Table2,xlsDonnée(fich,i,1,Faux),xlsDonnée(fich,i,2,Faux),xlsDonnée(fich,i,3,Faux))
    FIN
    كود Exporter Fichier Xls

    كود (text):
    sRépertoire est une chaîne
    sRépertoire = fRepSélecteur("", "")
    sNomf est une chaîne UNICODE
    Saisie("Nom du fichier",sNomf)
    mm est un xlsDocument
    xlsAjouteFeuille(mm,"a")
    POUR i=1 A TableOccurrence(Table2)
        mm[i,"A"]=Table2[i].Colonne1
        mm[i,"B"]=Table2[i].Colonne2
        mm[i,"C"]=Table2[i].Colonne3
    FIN
    SI xlsSauve(mm,sRépertoire+"\"+sNomf+".xls") ALORS
        xlsFerme(mm)
    FIN


    المشروع في الملفات المرفقة
     

    الملفات المرفقة:

    آخر تعديل: ‏8 مارس 2016
    biledi ،samorai2 ،merouane24000 و 4آخرون معجبون بهذا.
  2. ditarek

    ditarek عضو جديد

    إنضم إلينا في:
    ‏8 مارس 2016
    المشاركات:
    7
    الإعجابات المتلقاة:
    7
      20-04-2016 20:37
    juste une petite question comment faire pour sauvegarder les données importer dans la base de données et merci
     
    أعجب بهذه المشاركة Ahmed Jendoubi
  3. Ahmed Jendoubi

    Ahmed Jendoubi Developpeur Windev طاقم الإدارة

    إنضم إلينا في:
    ‏17 جوان 2013
    المشاركات:
    3.074
    الإعجابات المتلقاة:
    5.128
      20-04-2016 21:45
    par code

    كود (text):

    pour tout ligne de Table_xl
    note.nom = col_nom
    note_prenom=col_prenom
    hajoute(note)
    sachant que table note et note sont des exemples
     
  4. abdelhalim_info

    abdelhalim_info عضو جديد

    إنضم إلينا في:
    ‏24 ماي 2016
    المشاركات:
    10
    الإعجابات المتلقاة:
    3
      24-05-2016 12:27
    السلام عليكم
    شكرا لك على الدروس التي تقدمها جزاك الله خيرا
    وقع لدي مشكل بالدالة xlsfeuilleencours
    لم أعرف المشكل أترقب ردك و شكرا
     
  5. Ahmed Jendoubi

    Ahmed Jendoubi Developpeur Windev طاقم الإدارة

    إنضم إلينا في:
    ‏17 جوان 2013
    المشاركات:
    3.074
    الإعجابات المتلقاة:
    5.128
      24-05-2016 14:21
    أخ عبد الحليم كيف سأعرف أين الخطأ في مشروعك لان المشروع موجود و الفديو أهم دليل على عمل البرنامج
    قم بارفاق مشروعك و سأرى أين خطأك
     
    biledi و samorai2 معجبون بهذا.
  6. ammer2021

    ammer2021 عضو جديد

    إنضم إلينا في:
    ‏9 أفريل 2018
    المشاركات:
    27
    الإعجابات المتلقاة:
    0
      12-04-2018 11:41
    السلام عليكم هل استطيع استعمل بيانات من اكسال مثل تسجيلات طلاب الى برنامج تسيير ملفات الطلبة الى وينداف 20
     
  7. yassine choucha

    yassine choucha عضو جديد

    إنضم إلينا في:
    ‏7 جوان 2018
    المشاركات:
    12
    الإعجابات المتلقاة:
    10
      13-06-2018 16:04
    ممكن توضيح أكثر من فضلك ؟
    وماهو الفرق بين هذا الكود و الكود السابق ؟
     
  8. yassine choucha

    yassine choucha عضو جديد

    إنضم إلينا في:
    ‏7 جوان 2018
    المشاركات:
    12
    الإعجابات المتلقاة:
    10
      15-06-2018 15:42
    الأخ أحمد جندوبي ممكن كبفية إضافة نافذة للبحث عن رفم التسجيل و عند إبجاده إضافة السطر كامل في جدول جديد ليتم في الأخير طبعه
     
  9. yassine choucha

    yassine choucha عضو جديد

    إنضم إلينا في:
    ‏7 جوان 2018
    المشاركات:
    12
    الإعجابات المتلقاة:
    10
      15-06-2018 22:18
    الأخ أحمد جندوبي ممكن كبفية إضافة نافذة للبحث عن رفم التسجيل و عند إبجاده إضافة السطر كامل في جدول جديد ليتم في الأخير طبعه
     
  10. Ahmed Jendoubi

    Ahmed Jendoubi Developpeur Windev طاقم الإدارة

    إنضم إلينا في:
    ‏17 جوان 2013
    المشاركات:
    3.074
    الإعجابات المتلقاة:
    5.128
      18-06-2018 08:14
    هذا الكود لاظافة المعلومات التي استوردتها من الاكسال لقاعدة البيانات

    قم باظافة قاعدة بيانات أولا من ثم قم بوضع زر لاظافة ما تريد طبعه في ما بعد
    بالنسبة للبحث يمكنك أن تقوم باظافة champs de saisie للقيام بالبحث

    أخيرا عند طلب شئ قم بفتح موضوع في ذلك و الا لن تتم اجابتك
     
    أعجب بهذه المشاركة yassine choucha
جاري تحميل الصفحة...

مشاركة هذه الصفحة

جاري تحميل الصفحة...