درس برنامج ادارة المحلات و السوبر ماركت :الباركود

الموضوع في 'لغات البرمجة' بواسطة Ahmed Jendoubi, بتاريخ ‏6 جوان 2018.

  1. pink41

    pink41 عضو فعال

    إنضم إلينا في:
    ‏27 جانفي 2008
    المشاركات:
    352
    الإعجابات المتلقاة:
    216
      10-07-2018 09:25
    أشكرك أخي على الرد ربما لكل مبرمج طريقته
     
    ziad41 ،merouane24000 و biledi معجبون بهذا.
  2. biledi

    biledi عضو مميز

    إنضم إلينا في:
    ‏27 ماي 2012
    المشاركات:
    873
    الإعجابات المتلقاة:
    1.240
      10-07-2018 11:02
    السلام عليكم
    هذا ما توصلت اليه مع قليل من التحويرات كإظافة ال tva
    ولكن المشكل في supprime
    اريد لو سمحتم عند الضغ على رز supprime
    المجموع ينقص

     
  3. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    301
    الإعجابات المتلقاة:
    152
      10-07-2018 11:08
    كود (text):
    // Suppression de l'enregistrement courant
    TableSupprime(TABLE_Ligne_Commande, TableSelect(TABLE_Ligne_Commande))

    // Recalcule des totaux
    CalculeTotaux()

    ///////////////////////
    كود (text):
    PROCEDURE CalculeTotaux()
    //SAI_TotalHT=COL_Sous_Total
    //SAI_TotalTVA=COL_Sous_Total*0.18 //Sachant que TVA est 18%
    //SAI_TotalTTC=SAI_TotalHT+SAI_TotalTVA
    /////////////////
    //RAZ des totaux
    SAI_TotalHT=0
    SAI_TotalTTC=0
    SAI_TotalTVA=0

    //Parcours des lignes de la commande
    POUR TOUTE LIGNE DE TABLE_Ligne_Commande
       
        //Ajouter le total de la ligne au tota HT
        SAI_TotalHT+=TABLE_Ligne_Commande.COL_Sous_Total
    //    SAI_TotalTVA+=TABLE_Ligne_Commande.COL_Sous_Total*val(COMBO_TVA)
        SAI_TotalTVA+=TABLE_Ligne_Commande.COL_Sous_Total*Val(COMBO_TVA)
    FIN

    //Total TVA

    //Total TTC
    SAI_TotalTTC=SAI_TotalHT+SAI_TotalTVA
     
    boulasselamine و merouane24000 معجبون بهذا.
  4. biledi

    biledi عضو مميز

    إنضم إلينا في:
    ‏27 ماي 2012
    المشاركات:
    873
    الإعجابات المتلقاة:
    1.240
      12-07-2018 09:10
    السلام عليكم
    هذه المرحلة ال1

    code bouton appliquer
    كود (text):
    HLitRecherchePremier(articles,articles.libarticle,COMBO_Articles)
    SI HTrouve(articles) ALORS
        TableAjouteLigne(TABLE_facture_achat4,articles.reference,articles.libarticle,SAI_quantité,articles.prixHT,SAI_quantité*articles.prixHT,articles.image)
       
                       
    FIN

    calcul4()

    POUR TOUTE LIGNE DE TABLE_facture_achat4

    SAI_toatl_HT4 +=TABLE_facture_achat4.COL_Sous_total
    SAI_total_TVA4 +=TABLE_facture_achat4. COL_Sous_total*(COMBO_Tva/100)
    FIN
    SAI_total_TTC=SAI_toatl_HT4+SAI_total_TVA4
    code calcul()
    كود (text):
    PROCEDURE calcul4()

    //raz des totaux
    SAI_toatl_HT4=0
    SAI_total_TVA4=0
    SAI_total_TTC=0

     
    code bouton supprimer
    كود (text):
    TableSupprime(TABLE_facture_achat4)

    calcul4()
    POUR TOUTE LIGNE DE TABLE_facture_achat4
       
        SAI_toatl_HT4 +=TABLE_facture_achat4.COL_Sous_total
        SAI_total_TVA4 +=TABLE_facture_achat4. COL_Sous_total*(COMBO_Tva/100)
    FIN
    SAI_total_TTC=SAI_toatl_HT4+SAI_total_TVA4

     
     
    boulasselamine, ziad41, merouane24000 و 1 شخص آخر معجبون بهذا.
  5. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    301
    الإعجابات المتلقاة:
    152
      12-07-2018 21:11
    بارك الله فيك هل تمت العملية بنجاح اخي

    حاول تطبيق كود التعرف على المنتج واضافة العدد فقط دون اضافة السطر كامل
    الكود موجود لكن به خلل هل تريد ان ارفقه ويتم التعديل عليه معا
     
    biledi و merouane24000 معجبون بهذا.
  6. biledi

    biledi عضو مميز

    إنضم إلينا في:
    ‏27 ماي 2012
    المشاركات:
    873
    الإعجابات المتلقاة:
    1.240
      12-07-2018 21:49
    نعم
     
    أعجب بهذه المشاركة محمد بن أحمد أبو حذيفة
  7. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    301
    الإعجابات المتلقاة:
    152
  8. biledi

    biledi عضو مميز

    إنضم إلينا في:
    ‏27 ماي 2012
    المشاركات:
    873
    الإعجابات المتلقاة:
    1.240
      13-07-2018 09:04
    السلام عليكم
    شكرا اخي لوضعك البرنامج
    اريد ان أسال : لماذا لا تظهر جميع الحقول
     
    أعجب بهذه المشاركة محمد بن أحمد أبو حذيفة
  9. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    301
    الإعجابات المتلقاة:
    152
      13-07-2018 09:12
    بارك الله فيك نتعلم فقط

    اظن ان يوجد خلل في كود
    Ajouter_le_produit

    او Valide

    راجع الاكواد التي في المرف المرفق لاني جربتها وتعمل بشكل جيد
    او ارفقها هنا
     
  10. biledi

    biledi عضو مميز

    إنضم إلينا في:
    ‏27 ماي 2012
    المشاركات:
    873
    الإعجابات المتلقاة:
    1.240
      13-07-2018 09:41
    ==========
    فعلا اخي يبدو ان الخطأ في كود valider
    قمت بإعادة كتابة الكود
    والأمور عال العال
    code bouton valider
    كود (text):
    SI SAI_Date_achat ~= "" ALORS
        Erreur("Vous devez saisir une date de Facture.")
        RepriseSaisie(SAI_Date_achat)
    FIN
    SI COMBO_Fournisseurs <=0 ALORS
        Erreur("Vous devez sélectionner un Fournisseur.")
        RepriseSaisie(COMBO_Fournisseurs)
       
    FIN
    SI TABLE_facture_achat4..Occurrence = 0 ALORS
        Erreur("Vous devez ajouter au moins 1 produit dans la commande.")
        RepriseSaisie(TABLE_facture_achat4)
       
    FIN

    // Ajoute la Facture
    HRAZ(achat)
    achat.date_achat     = SAI_Date_achat
    achat.Numero_facture_achat = SAI_Numero_facture_achat
    achat.IDfournisseurs = COMBO_Fournisseurs
    achat.total_ht         = SAI_toatl_HT4
    achat.total_tva         = SAI_total_TVA4
    achat.total_ttc        = SAI_total_TTC
    HAjoute(achat)

    // Ajoute les lignes de commande
    POUR TOUTE LIGNE DE TABLE_facture_achat4
        HRAZ(ligne_achat)
        ligne_achat.Num_achat     = achat.Num_achat
        ligne_achat.prix_ht         = COL_Prix_ht
        ligne_achat.quantité         = COL_Quantité
        ligne_achat.libarticle    = COL_Article
        ligne_achat.IDarticles = COL_Reference
        HAjoute(ligne_achat)
       
       
        // Il faut modifier le stock du produit en conséquence
       
        HLitRecherchePremier(articles, articles.libarticle, ligne_achat.libarticle)
        SI HTrouve(articles) = Faux ALORS
            HRAZ(articles)
            articles.libarticle = ligne_achat.libarticle
            HAjoute(articles)  
        FIN
       
        // XX produit en plus en stock
       
        articles.quantité         +=  ligne_achat.quantité
        HModifie(articles)
    FIN



    // Ferme la fenêtre
    Ferme("", Vrai)
     
     
    أعجب بهذه المشاركة محمد بن أحمد أبو حذيفة
جاري تحميل الصفحة...
مواضيع مشابهة التاريخ
برنامج ادارة صندوق المال gestion de caisse windev ‏20 أكتوبر 2018
برنامج :"البيع بالتقسيط" ‏9 أفريل 2018
برنامج صغير راديو بالونديف ‏14 ديسمبر 2017

مشاركة هذه الصفحة

جاري تحميل الصفحة...