حلت طلب طريقة البحث في الكمبو

الموضوع في 'طلبات لغات التطوير و البرمجة' بواسطة محمد بن أحمد أبو حذيفة, بتاريخ ‏13 ديسمبر 2018.

  1. redha2010

    redha2010 عضو نشيط

    إنضم إلينا في:
    ‏8 جوان 2018
    المشاركات:
    216
    الإعجابات المتلقاة:
    279
      13-12-2018 21:37
    saisie assisté معناها يختلف عن الفلترة Filtrage فهو يساعدك فقط لتكملة الكتابة
    هذا هو الهدف منها
     
    أعجب بهذه المشاركة محمد بن أحمد أبو حذيفة
  2. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    364
    الإعجابات المتلقاة:
    174
      13-12-2018 21:39
    الا يوجد حل اخر لفتح الكمبو

    وهل الفكرة التي ارفقتها في الفيديو جيدة
    ام انها متعبة
     
  3. redha2010

    redha2010 عضو نشيط

    إنضم إلينا في:
    ‏8 جوان 2018
    المشاركات:
    216
    الإعجابات المتلقاة:
    279
    أفضل إجابة
      13-12-2018 22:03
    يمكنك استعمال champs saisie غير مربوط بقاعدة بياناتك
    وبالكود تقوم بملء الناتج
    كود (text):
    SaisieAssistéeSupprimeTout(SAI_SansNom1)
    SI SAI_SansNom1<>"" ALORS
    POUR TOUT Client AVEC "NomClient" [=SAI_SansNom1 DEPUISFIN
        SaisieAssistéeAjoute(SAI_SansNom1,Client.NomClient)
       
    FIN
    SaisieAssistéeOuvre(SAI_SansNom1)
    FIN
    upload_2018-12-13_22-3-40.png
     

    الملفات المرفقة:

    • TEST_COMBO.rar
      TEST_COMBO.rar
      حجم الملف:
      488,4 ك. ب
      المشاهدات:
      68
  4. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    364
    الإعجابات المتلقاة:
    174
      13-12-2018 22:07
    بارك الله فيك ورحمك فكرة جيد جدا
    تم حل المشكلة

    لكن لم اجد زر افضل اجابة
     
  5. kelam

    kelam عضو مميز في منتدى الهندسة المدنية والمعمارية

    إنضم إلينا في:
    ‏3 ديسمبر 2016
    المشاركات:
    1.181
    الإعجابات المتلقاة:
    1.745
      15-12-2018 05:21
    بارك الله فيك يا اخ رضا فعلا هذا المثال مرجع للكومبو جميل جدا
     
    أعجب بهذه المشاركة محمد بن أحمد أبو حذيفة
  6. aissaz21

    aissaz21 عضو

    إنضم إلينا في:
    ‏19 نوفمبر 2018
    المشاركات:
    87
    الإعجابات المتلقاة:
    48
      10-01-2019 21:42
    مشكور اخي
     
    آخر تعديل: ‏10 جانفي 2019 في 21:55
  7. aissaz21

    aissaz21 عضو

    إنضم إلينا في:
    ‏19 نوفمبر 2018
    المشاركات:
    87
    الإعجابات المتلقاة:
    48
      10-01-2019 22:39
    هناك مشكلة في البحث ’ كيفية جعل البحث داخل الاسم
    كود (text):
    ]    Contient    Valable pour les types "chaîne" uniquement
    ]=    Commence par    Valable pour les types "chaîne" uniquement
     
  8. aissaz21

    aissaz21 عضو

    إنضم إلينا في:
    ‏19 نوفمبر 2018
    المشاركات:
    87
    الإعجابات المتلقاة:
    48
      10-01-2019 23:06
    اخي جربت هذا الكود ولكن المشكلة في البحث بالعربية
    كود (text):
    SaisieAssistéeSupprimeTout(MoiMême)
    SI MoiMême = "" ALORS
        SaisieAssistéeFerme(MoiMême)
    SINON
       
        HFiltreContient(Produit,Produit.Designation,MoiMême)
        HLitPremier(Produit,Produit.IDProduit,hRespecteFiltre)
        TANTQUE PAS HEnDehors(Produit)
            SaisieAssistéeAjoute(MoiMême,Produit.Designation)
            HLitSuivant(Produit)  
        FIN
        HDésactiveFiltre(Produit)
        SaisieAssistéeOuvre(MoiMême)
    FIN
     
    أعجب بهذه المشاركة محمد بن أحمد أبو حذيفة
  9. محمد بن أحمد أبو حذيفة

    محمد بن أحمد أبو حذيفة عضو فعال

    إنضم إلينا في:
    ‏14 أفريل 2016
    المشاركات:
    364
    الإعجابات المتلقاة:
    174
      11-01-2019 08:30
    الكود يعمل عادي
    الكود المستعمل
    كود (text):
    SaisieAssistéeSupprimeTout(SAI_SansNom1)
    SI SAI_SansNom1<>"" ALORS
    POUR TOUT Client AVEC "NomClient" [=SAI_SansNom1 DEPUISFIN
        SaisieAssistéeAjoute(SAI_SansNom1,Client.NomClient)
       
    FIN
    SaisieAssistéeOuvre(SAI_SansNom1)
    FIN
     
    sshot-1.png
     
    آخر تعديل: ‏11 جانفي 2019 في 08:51
  10. aissaz21

    aissaz21 عضو

    إنضم إلينا في:
    ‏19 نوفمبر 2018
    المشاركات:
    87
    الإعجابات المتلقاة:
    48
      11-01-2019 10:23
    اجل اخي هذا الكود يعمل بالعربية ولكن طريقة البحث يبدأ من اول الكلمة وليس وسط الكلمة
     
جاري تحميل الصفحة...
مواضيع مشابهة التاريخ
حلت اللغة العربية في البحث ‏5 أفريل 2018
حلت البحث ‏22 نوفمبر 2018
حلت ممكن طريقة عكس الاظهار في جداول البيانات ‏3 أفريل 2018

مشاركة هذه الصفحة

جاري تحميل الصفحة...