طلب Fichier.txt

tito28

عضو مميز في برمجة الوينداف
إنضم
4 أفريل 2016
المشاركات
221
مستوى التفاعل
205
السلام عليكم ورحمة الله وبركاته
أريد قراءة ملف نصي TXT وتحويل المعلومات إلى قاعدة البيانات SALARIE.Fic
لقد إستعملت هذا الكود لكنه لم يفلح
 

المرفقات

redha2010

عضو فعال
إنضم
8 جوان 2018
المشاركات
367
مستوى التفاعل
413
وعليكم السلام ورحمة الله وبركاته
لا يوجد أي مشكل في الكود

يمكنك استخدام الكود في حالة عدم وجود فاصلة
كود:
NomChemin est une chaîne
varLigne est une chaîne
IDFichier est un entier

NomChemin = fSélecteur(fRepExe(), "", ...
"Sélectionnez un fichier...", ...
"Tous fichiers (*.TXT)"+TAB+"*.TXT", "TXT",foLecture)

// Ouverture du fichier
IDFichier = fOuvre(NomChemin,foLecture)

// Affichage du message d'erreur si l'ouverture n'a pas été effectuée
SI IDFichier = -1 ALORS
    Erreur(ErreurInfo(errMessage))
SINON
   
    varLigne = fLitLigne(IDFichier)
    TANTQUE varLigne <> EOT ET varLigne <> ""
       
         SALARIE.Num_Compte = Milieu(varLigne,1,10)
        SALARIE.Clé_Compte =Milieu(varLigne,11,2)
         SALARIE.Montant    =Milieu(varLigne,13,7)
         SALARIE.Nom        = Milieu(varLigne,20)
//         SALARIE.Prenom     = ExtraitChaîne(varLigne,5,";")
        //info(ExtraitChaîne(varLigne,2,";")  )
       
         HAjoute(SALARIE)
        varLigne = fLitLigne(IDFichier)
    FIN
    TableAffiche(TABLE_SALARIE)
    fFerme(IDFichier)      
FIN
تطبيق مرفق
 

المرفقات

  • 1,1 MB المشاهدات: 51
التعديل الأخير:

aissaz21

عضو نشيط
إنضم
19 نوفمبر 2018
المشاركات
215
مستوى التفاعل
126
ممكن الطريقة العكسية من قاعدة البيانات الى ملف txt
 
أعلى