Lire l'audio et la vidéo sous Ubuntu Jaunty (9.04)

الموضوع في 'أنظمة GNU Linux' بواسطة roma33, بتاريخ ‏25 أفريل 2009.

  1. roma33

    roma33 عضو فعال

    إنضم إلينا في:
    ‏12 جوان 2007
    المشاركات:
    487
    الإعجابات المتلقاة:
    1.564
      25-04-2009 21:24
    :besmellah1:

    Introduction

    Ce tuto s'adresse surtout aux débutants sous Ubuntu. Sautez cette section si vous en êtes habitué ou lisez-la pour vous rafraîchir la cervelle :191: .

    Vous êtes certainement habitué à l'installation / désinstallation de logiciels sous Window$. Pour installer un logiciel, on va chercher un fichier nommé setup.exe ou install.exe, on effectue un double clic, on clique 'suivant' 'suivant' 'suivant' ... et voila le programme 'fonctionnel'. Et si on veut le mettre à jour pour corriger un bug ou ajouter une fonctionnalité ou même passer à une version plus récente, il faut exécuter le programme, rechercher une option 'mettre à jour', etc.... C'est à dire chaque programme installé doit être mis à jour à part. Pensez au nombre de programmes que vous avez déjà sur votre ordinateur et regardez ceux qui sont à jour. Vous comprenez peut-être un peut pourquoi il est très difficile, voir impossible d'avoir un système Window$ bien sécurisé. Même si vous avez un antimalware et un système à jour, vous n'êtes pas à l'abri des attaques à cause des bugs de sécurité des autres programmes.

    Et bien, ce n'est pas le cas sous Linux.

    Tout d'abord, sous Linux on dit 'paquet'. Un paquet est tout simplement une archive se terminant par l'extension 'deb' pour des distribution basées sur Debian, 'rpm' pour les distributions basées sur RedHat, ainsi que d'autres extensions comme 'run', 'tar.gz' etc...(FixMe).

    On peut même compiler soi-même un paquet si on a le code source et les dépendances nécessaires, mais ceci dépasse le cadre de notre tuto.

    Dans ce qui suit, je vais parler seulement de l'installation de paquets sous Ubuntu (et les dérivés de Debian peut-être).

    Pour installer ou désinstaller un paquet sous Ubuntu, c'est APT qu'il faut appeler (APT = Advanced Package Tool). C'est une sorte de gestionnaire qui gère l'installation et la désinstallation de n'importe quel paquet (logiciel) sous Ubuntu.

    On peut appeler APT de plusieurs façons ( dans tous les cas,il vous sera demandé votre mot de passe root "sudo"):

    - A partir de la ligne de commande: sudo apt-get install <paquet> et pour désinstaller: sudo apt-get remove <paquet>

    - A partir du menu Applications --> Ajouter/supprimer...

    - A partir du menu Système --> Administration --> Gestionnaire de paquets Synaptic

    - A partir de votre navigateur web (Firefox) en cliquant sur un lien trouvé dans Internet

    - En double-cliquant sur un fichier 'Deb' précédemment téléchargé

    - ......

    Ensuite, APT, par le biais d'un service de mise à jour (qu'on peut invoquer en ligne de commande ou à partir du menu Système --> Administration --> Gestionnaire de mise à jour) va régulièrement vérifier l'existence de mise à jour pour le système et tous les paquets installés de cette manière et vous serez donc toujours à jour sans aucun effort de votre part.

    Allons maintenant à l'essentiel.

    :tunis::tunis::tunis:
     
    2 شخص معجب بهذا.

  2. roma33

    roma33 عضو فعال

    إنضم إلينا في:
    ‏12 جوان 2007
    المشاركات:
    487
    الإعجابات المتلقاة:
    1.564
      25-04-2009 21:33
    :besmellah1:

    (connection internet nécessaire)

    Assurez-vous d'avoir activé les dépôts:

    - Universe et Multiverse

    - Canonical Commercial

    - Medibuntu

    Ces dépôts contiennent les paquets qui permettront l'utilisation des fichiers ayant des formats non libres (propriétaires).

    Pour se faire:

    1) Système --> Administration --> Sources de mise à jour (ou sources de logiciels selon la version de votre distribution).

    2) Entrez votre mot de passe root

    3) Vérifiez, dans l'anglet "Logiciel de Ubuntu", que les cases "Logiciels libres maintenus par la communauté" et "Logiciel soumis au droit d'auteur ou à des restrictions légales" sont bien cochées. Il est d'ailleurs recommandé de cocher les 4 premières cases.

    4) Fermez le gestionnaire de Sources de mise à jour

    Pour le dépôt Medibuntu, il vous faut une clé d'authentification que vous téléchargerez et installerez en exécutant la commande suivante, dans un terminal:

    -------------------------------------------------------------------------------------

    كود (text):
    wget -q http://fr.packages.medibuntu.org/medibuntu-key.gpg -O- | sudo apt-key add -
     
    -------------------------------------------------------------------------------------

    A partir de maintenant, vous êtes en mesure d'installer plusieurs paquets non libres (ici non libre ne veut pas dire un logiciel payant, mais un logiciel dont l'utilisation est restreinte d'une manière ou d'une autre; par ex: on n'a pas le droit de le modifier).
    Pour une liste complète des paquets medibuntu, Visitez le site:
    http://www.medibuntu.org/

    5) Ré-ouvrez le gestionnaire de Sources de mise à jour et passez à l'anglet: "Logiciels tierces parties".

    Ajoutez l'une des sources suivantes selon la version de votre distribution:

    Jaunty (9.04):

    كود (text):
    deb http://packages.medibuntu.org/ jaunty free non-free
     
    Intrepid (8.10):
    كود (text):
    deb http://packages.medibuntu.org/ intrepid free non-free
     
    Hardy (8.04):

    كود (text):
    deb http://packages.medibuntu.org/ hardy free non-free
    Fermez le gestionnaire et acceptez d'actualiser la liste
    A suivre ...
    :tunis::tunis::tunis:
     
    1 person likes this.
  3. roma33

    roma33 عضو فعال

    إنضم إلينا في:
    ‏12 جوان 2007
    المشاركات:
    487
    الإعجابات المتلقاة:
    1.564
      25-04-2009 21:42

    Il vous faut maintenant installer les codecs:

    1) Allez dans Système --> Administration --> Gestionnaire de paquets Synaptic

    2) Entrez votre mot de passe root

    3) Recherchez et sélectionnez pour installation: non-free-codecs

    4) Avec le bouton droit de votre souris, choisissez 'Sélectionner pour installation'

    5) Acceptez l'installation des dépendances

    6) Validez en cliquant sur Appliquer

    Patientez car plus de 100 Mo vont être télécharger et installer. Passez votre temps à lire d'autres sections dans le forum ou testez les jeux installés avec votre distribution. En ce qui conserne les jeux, il n'y a vraiment pas de comparaison avec ceux de Window$, disons-le clairement. A mon avis, ce n'est pas chose qui fait honte à Linux puisqu'on peut jouer en ligne si les centaines de jeux proposés en libre téléchargement ne conviennent pas. Et il y a Wine, un paquet qui fait fonctionner des Applications Window$ (pas toutes les applications)à l'intérieur même de Linux. Sur les ordinateurs récents, on peut aussi créer une machine virtuelle (avec VirtualBox ou VMWare) si on ne peut pas se passer de ses habitudes windowsiennes.

    Voilà, le tuto est terminé. J'espère que je vous ai donné quelques informations pour vous faciliter la vie avec votre distribution.
    Bonne lecture! :kiss:
    :tunis::tunis::tunis:
     
    2 شخص معجب بهذا.
  4. mr.tunisiano

    mr.tunisiano عضو مميز

    إنضم إلينا في:
    ‏27 فيفري 2008
    المشاركات:
    1.184
    الإعجابات المتلقاة:
    892
      16-05-2009 21:31
    j'ai UBUNTU et dans ta liste de sources il y'a pas une qui est pour cette version
     
  5. akrem01

    akrem01 عضو

    إنضم إلينا في:
    ‏20 جانفي 2009
    المشاركات:
    78
    الإعجابات المتلقاة:
    28
      16-05-2009 22:56

    :besmellah1:


    inchalah natle3 fhemtek!!!!!!!!!!!!!!o

    ok , tu as besoin simplement de mettre à jour seulement la liste des paquets
    pou celà
    1/ ouvre le gestionnaire des paquets
    2/ recharger la liste
    3/ riguel omourek

    si mouch hetha elli te7ki 3lih prière de préciser ta demande...............merci

     
  6. roma33

    roma33 عضو فعال

    إنضم إلينا في:
    ‏12 جوان 2007
    المشاركات:
    487
    الإعجابات المتلقاة:
    1.564
      17-05-2009 00:58
    Prière de préciser ta question
    tu as ubuntu 8.04 donc c'est Hardy
    tu as ubuntu 8.10 donc c'est Intrepid
    tu as ubuntu 9.04 donc c'est Jaunty
    Si tu as une version plus ancienne que Hardy, le tuto ne te convient pas
     

  7. roma33

    roma33 عضو فعال

    إنضم إلينا في:
    ‏12 جوان 2007
    المشاركات:
    487
    الإعجابات المتلقاة:
    1.564
      18-05-2009 23:47
    2 شخص معجب بهذا.
جاري تحميل الصفحة...
مواضيع مشابهة التاريخ
حلت adresse ubuntu vbox et windows7 ‏19 مارس 2016
ubuntu ‏12 نوفمبر 2016
probleme ubuntu ‏24 نوفمبر 2016

مشاركة هذه الصفحة

جاري تحميل الصفحة...